Yes! Duet FireWire, Duet 2 and Duet for iPad/Mac are all fully compatible* with Mac OS X El Capitan (10.11 to current).  Please be sure to download and install the latest El Capitan compatible software package for your product from Apogee’s site.

*  Although Duet FireWire is not “officially supported” after OS X 10.10.5, it is still compatible with OS X 10.11 and should work just like it did on OS X 10.10. You can download the latest installer for Duet Firewire and use it on 10.11 even though it says “Mac OS X 10.10 and 10.9 only”.

 

Click to find the latest Duet FireWire Software Installer

Click to find the latest Duet 2 Software Installer

Click to find the latest Duet for iPad/Mac Software Installer